fix kmod-ide-core packaging for 2.6.26+
[openwrt-10.03/.git] / package / kernel / modules / block.mk
index 9a4d6ffb767d380a5e7933a86d68655f4a4b0694..3f8bd465b33f3a929351f5cc43b4d2123fa03d5f 100644 (file)
@@ -11,7 +11,7 @@ BLOCK_MENU:=Block Devices
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT @LINUX_2_6
+  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,libata)
@@ -20,10 +20,26 @@ endef
 $(eval $(call KernelPackage,ata-core))
 
 
+define KernelPackage/ata-ahci
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=AHCI Serial ATA support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_SATA_AHCI
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,ahci)
+endef
+
+define KernelPackage/ata-ahci/description
+ Support for AHCI Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-ahci))
+
+
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support
-  DEPENDS:=kmod-ata-core +kmod-scsi-core
+  DEPENDS:=kmod-ata-core
   KCONFIG:=CONFIG_PATA_ARTOP
   FILES:=$(LINUX_DIR)/drivers/ata/pata_artop.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,41,pata_artop)
@@ -36,29 +52,74 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-ixp4xx-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=IXP4XX Compact Flash support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_PATA_IXP4XX_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf)
+endef
+
+define KernelPackage/ata-ixp4xx-cf/description
+ IXP4XX Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-ixp4xx-cf))
+
+
+define KernelPackage/ata-nvidia-sata
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Nvidia Serial ATA support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_SATA_NV
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_nv.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,sata_nv)
+endef
+
+$(eval $(call KernelPackage,ata-nvidia-sata))
+
+
 define KernelPackage/ata-piix
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Intel PIIX PATA/SATA support
-  DEPENDS:=kmod-ata-core +kmod-ide-core +kmod-scsi-core
+  DEPENDS:=kmod-ata-core
   KCONFIG:=CONFIG_ATA_PIIX
   FILES:=$(LINUX_DIR)/drivers/ata/ata_piix.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,41,ata_piix)
 endef
 
 define KernelPackage/ata-piix/description
- SATA support for Intel ICH5/6/7/8 series host controllers and 
+ SATA support for Intel ICH5/6/7/8 series host controllers and
  PATA support for Intel ESB/ICH/PIIX3/PIIX4 series host controllers.
 endef
 
 $(eval $(call KernelPackage,ata-piix))
 
 
+define KernelPackage/ata-via-sata
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=VIA SATA support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_SATA_VIA
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_via.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,sata_via)
+endef
+
+define KernelPackage/ata-via-sata/description
+ This option enables support for VIA Serial ATA.
+endef
+
+$(eval $(call KernelPackage,ata-via-sata))
+
+
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
   KCONFIG:= \
        CONFIG_IDE \
        CONFIG_IDE_GENERIC \
+       CONFIG_BLK_DEV_GENERIC \
        CONFIG_BLK_DEV_IDE \
        CONFIG_IDE_GENERIC \
        CONFIG_BLK_DEV_IDEDISK \
@@ -75,10 +136,17 @@ define KernelPackage/ide-core/2.4
   AUTOLOAD+=$(call AutoLoad,30,ide-detect)
 endef
 
-define KernelPackage/ide-core/2.6
-  FILES+=$(LINUX_DIR)/drivers/ide/ide-generic.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD+=$(call AutoLoad,30,ide-generic)
-endef
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
+  define KernelPackage/ide-core/2.6
+    FILES+=$(LINUX_DIR)/drivers/ide/pci/ide-pci-generic.$(LINUX_KMOD_SUFFIX)
+    AUTOLOAD+=$(call AutoLoad,30,ide-pci-generic)
+  endef
+else
+  define KernelPackage/ide-core/2.6
+    FILES+=$(LINUX_DIR)/drivers/ide/ide-generic.$(LINUX_KMOD_SUFFIX)
+    AUTOLOAD+=$(call AutoLoad,30,ide-generic)
+  endef
+endif
 
 define KernelPackage/ide-core/description
  Kernel support for IDE, useful for usb mass storage devices (e.g. on WL-HDD)
@@ -95,7 +163,7 @@ define KernelPackage/ide-aec62xx
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Acard AEC62xx IDE driver
   DEPENDS:=@PCI_SUPPORT +kmod-ide-core
-  KCONFIG:=CONFIG_BLK_DEV_AEC62XX 
+  KCONFIG:=CONFIG_BLK_DEV_AEC62XX
   FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,aec62xx)
 endef
@@ -117,7 +185,7 @@ define KernelPackage/ide-pdc202xx
 endef
 
 define KernelPackage/ide-pdc202xx/description
- Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE 
+ Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE
  controllers.
 endef
 
@@ -184,16 +252,17 @@ endef
 $(eval $(call KernelPackage,nbd))
 
 
-define KernelPackage/rb153-cf
+define KernelPackage/pata-rb153-cf
   SUBMENU:=$(BLOCK_MENU)
-  TITLE:=RouterBoard 153 CF Slot
-  KCONFIG:=CONFIG_BLK_DEV_CF_MIPS
-  FILES:=$(LINUX_DIR)/drivers/block/rb1xx/rb153-cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,rb153-cf)
+  DEPENDS:=kmod-ata-core @TARGET_adm5120_router_le
+  TITLE:=RouterBOARD 153 CF Slot support
+  KCONFIG:=CONFIG_PATA_RB153_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf)
 endef
 
-define KernelPackage/rb153-cf/description
-  Kernel module for the RouterBoard 153 CF slot
+define KernelPackage/pata-rb153-cf/description
+  Kernel support for the RouterBoard 153 CF slot.
 endef
 
-$(eval $(call KernelPackage,rb153-cf))
+$(eval $(call KernelPackage,pata-rb153-cf))