don't try to create kmod packages that contain no files
[openwrt-10.03/.git] / package / kernel / Makefile
index c977501e089f511ea7be56e149b83d6b647b7427..b1155f4286672e164f259d5c7a5599ad8c5f1611 100644 (file)
@@ -72,12 +72,14 @@ define KernelPackage
   endef
 
   ifeq ($(findstring m,$(KCONFIG)),m)
+  ifneq ($(strip $(FILES)),)
     define Package/kmod-$(1)/install
                mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
                $(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
                $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
     endef
   endif
+  endif
   $$(eval $$(call BuildPackage,kmod-$(1)))
 endef