ath9k: rework tx power handling - display the correct *current* tx power, and also...
[openwrt-10.03/.git] / package / kernel / Makefile
index 036af764f14353c7fad4793e25dfef64cc900558..39e38f9214902da2ae061b601d3289d5809f09e9 100644 (file)
@@ -4,12 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
 SCAN_DEPS=modules/*.mk
@@ -35,7 +35,7 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
 endef
 
 define Package/kernel/install
@@ -44,5 +44,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
+-include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk