[backfire] merge r26968
[openwrt-10.03/.git] / package / iw / Makefile
index e917739129617b0c4fc6d18d568e726eced80a43..2b714f8f9897a9bc17638d0a1999887dc46ecc65 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
-PKG_VERSION:=0.9.15
-PKG_RELEASE:=1
+PKG_VERSION:=0.9.22
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://wireless.kernel.org/download/iw/
-PKG_MD5SUM:=98ba12eceec5a4ae8aa2d51abd56fa14
+PKG_MD5SUM:=561c2602c5ce7c65a590118286c0892a
 PKG_BUILD_DEPENDS:=mac80211
 
 include $(INCLUDE_DIR)/package.mk
@@ -23,7 +23,7 @@ define Package/iw
   CATEGORY:=Network
   TITLE:=cfg80211 interface configuration utility
   URL:=http://wireless.kernel.org/en/users/Documentation/iw
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +libnl-tiny
+  DEPENDS:= +libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
 endef
 
 define Build/Configure
@@ -48,11 +48,9 @@ MAKE_FLAGS += \
        LIBS="-lm -lnl-tiny" \
        V=1
 
-ifneq ($(CONFIG_LINUX_2_6),)
-  define Package/iw/install
+define Package/iw/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/iw $(1)/usr/sbin/
-  endef
-endif
+endef
 
 $(eval $(call BuildPackage,iw))