[package] iptables: fix a segfault when iptables tries to use modprobe, force it...
[openwrt-10.03/.git] / package / iptables / Makefile
index 20e4b315caa5f915e230716f2b07453439040c41..68ccc76282ac422ea09761878a152c41443ff33d 100644 (file)
@@ -254,6 +254,10 @@ TARGET_CPPFLAGS := \
        -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
        $(TARGET_CPPFLAGS)
 
+TARGET_CFLAGS := \
+       $(TARGET_CFLAGS) \
+       -DFORCE_MODPROBE_PROGRAM="\\\"/sbin/insmod\\\""
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-devel \