Update iproute2 to version 2.6.25, and fixup patches
[openwrt-10.03/.git] / package / iproute2 / patches / 006-iproute2-tc_esfq.patch
index d0347549dd26f6e14e6b43ecfd51af0c8806a8c9..29a51224bdbf9dad12e5dcf73e7d3bf43a949055 100644 (file)
@@ -1,7 +1,8 @@
-diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iproute2-2.6.11-050330/include/linux/pkt_sched.h
---- iproute2-2.6.11-050330/include/linux/pkt_sched.h   2007-05-04 22:21:48.000000000 -0400
-+++ iproute2-2.6.11-050330/include/linux/pkt_sched.h   2007-05-04 22:27:12.000000000 -0400
-@@ -174,8 +174,38 @@
+Index: iproute2-2.6.25/include/linux/pkt_sched.h
+===================================================================
+--- iproute2-2.6.25.orig/include/linux/pkt_sched.h     2008-05-01 00:37:45.000000000 +0100
++++ iproute2-2.6.25/include/linux/pkt_sched.h  2008-05-01 20:30:49.000000000 +0100
+@@ -174,8 +174,38 @@ struct tc_sfq_qopt
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -40,7 +41,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
  /* RED section */
  
  enum
-@@ -551,8 +580,37 @@
+@@ -568,8 +598,37 @@ struct tc_sfq_xstats
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -78,10 +79,11 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
  /* RED section */
  
  enum
-diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-050330/tc/Makefile
---- iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:21:48.000000000 -0400
-+++ iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:27:37.000000000 -0400
-@@ -6,6 +6,7 @@
+Index: iproute2-2.6.25/tc/Makefile
+===================================================================
+--- iproute2-2.6.25.orig/tc/Makefile   2008-05-01 00:30:13.000000000 +0100
++++ iproute2-2.6.25/tc/Makefile        2008-05-01 20:30:49.000000000 +0100
+@@ -7,6 +7,7 @@ include ../Config
  TCMODULES :=
  TCMODULES += q_fifo.o
  TCMODULES += q_sfq.o
@@ -89,9 +91,10 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-0503
  TCMODULES += q_red.o
  TCMODULES += q_prio.o
  TCMODULES += q_tbf.o
-diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-050330/tc/q_esfq.c
---- iproute2-2.6.11-050330/tc/q_esfq.c 1969-12-31 19:00:00.000000000 -0500
-+++ iproute2-2.6.11-050330/tc/q_esfq.c 2007-05-04 22:37:54.000000000 -0400
+Index: iproute2-2.6.25/tc/q_esfq.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ iproute2-2.6.25/tc/q_esfq.c        2008-05-01 20:31:09.000000000 +0100
 @@ -0,0 +1,200 @@
 +/*
 + * q_esfq.c           ESFQ.
@@ -114,7 +117,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +#include <unistd.h>
 +#include <syslog.h>
 +#include <fcntl.h>
-+#include <math.h> 
++#include <math.h>
 +#include <sys/socket.h>
 +#include <netinet/in.h>
 +#include <arpa/inet.h>
@@ -140,7 +143,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +      memset(&opt, 0, sizeof(opt));
 +
 +      opt.hash_kind= TCA_SFQ_HASH_CLASSIC;
-+      
++
 +      while (argc > 0) {
 +              if (strcmp(*argv, "quantum") == 0) {
 +                      NEXT_ARG();
@@ -186,7 +189,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +                      NEXT_ARG();
 +                      if(strcmp(*argv, "classic") == 0) {
 +                              opt.hash_kind= TCA_SFQ_HASH_CLASSIC;
-+                      } else 
++                      } else
 +                      if(strcmp(*argv, "dst") == 0) {
 +                              opt.hash_kind= TCA_SFQ_HASH_DST;
 +                      } else