refresh all package patches in the buildroot using quilt
[openwrt-10.03/.git] / package / iproute2 / Makefile
index e494177c90d1ef5354e08ac06e13da53326deb75..600c7734cb81cd6acf4a8321e0f51dbd98eac85a 100644 (file)
@@ -12,24 +12,26 @@ PKG_NAME:=iproute2
 PKG_VERSION:=2.6.15-060110
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
 PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/iproute2/Default
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://linux-net.osdl.org/index.php/Iproute2
+endef
+
 define Package/ip
-SECTION:=base
-CATEGORY:=Network
-DEPENDS:=iproute2
-TITLE:=A routing control utility
+  $(call Package/iproute2/Default)
+  TITLE:=Routing control utility
 endef
 
 define Package/tc
-$(call Package/ip)
-TITLE:=A traffic control utility
+  $(call Package/iproute2/Default)
+  TITLE:=Traffic control utility
 endef
 
 define Build/Configure
@@ -45,19 +47,23 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
+       $(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
 endef
 
 define Package/ip/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
 define Package/tc/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
+
+$(eval $(call RequireCommand,bison, \
+       $(PKG_NAME) requires GNU bison. \
+))