hotplug2: add a missing cflag, allow hotplug events that are not 'add'
[openwrt-10.03/.git] / package / hotplug2 / Makefile
index 6c2a0a10517936d91ce4ab59ff573351b64d3c05..c696f09f5bc536b2e50c89ff2243f3ef247f4da8 100644 (file)
@@ -21,7 +21,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/hotplug2
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6 +udevtrigger
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
@@ -30,8 +29,12 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
 
 define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
+       $(INSTALL_DATA) ./files/hotplug2-init.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef