[backfire] backport r26807
[openwrt-10.03/.git] / package / hotplug2 / Makefile
index ee35bd6fcef24d93fcf5a018b3ff9e2f08636453..9eb574e4ce35dbeb71bb325bed58af6be18a3d7e 100644 (file)
@@ -1,36 +1,48 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6372 2007-02-25 23:34:57Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hotplug2
-PKG_VERSION:=0.9
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
-PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
+PKG_REV:=201
+PKG_VERSION:=$(PKG_REV)
+PKG_RELEASE:=3
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+#PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
+#PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
-  SECTION:=utils
-  CATEGORY:=Utilities
-  VERSION:=0.9+r102-$(PKG_RELEASE)
-  TITLE:=Dynamic device management subsystem for embedded systems
+  SECTION:=base
+  CATEGORY:=Base system
+  VERSION:=1.0-beta-$(PKG_RELEASE)
+  TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
 
 define Package/hotplug2/description
-Hotplug2 is a trivial replacement of some of the UDev functionality
-in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ Hotplug2 is a trivial replacement of some of the UDev functionality
+ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ This is an implementation of Hotplug2-1.0-beta
 endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
+
+define Package/hotplug2/conffiles
+/etc/hotplug2.rules
+endef
+
+MAKE_FLAGS += \
+       COPTS="$(TARGET_CFLAGS)" \
+       STATIC_WORKER="fork"
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc