hostapd: update to latest version from trunk (fixes #10455)
[openwrt-10.03/.git] / package / hostapd / patches / 700-random_pool_add_kernel.patch
index 1edaff9e7732f93339f98ed31bb6732aa7f85880..1a30a0266e87978243280dc7cc01c2024ff3af23 100644 (file)
@@ -1,6 +1,15 @@
 --- a/src/crypto/random.c
 +++ b/src/crypto/random.c
-@@ -47,6 +47,8 @@
+@@ -38,6 +38,8 @@
+ #include "sha1.h"
+ #include "random.h"
++#define RANDOM_STAMPFILE "/var/run/.random_available"
++
+ #define POOL_WORDS 32
+ #define POOL_WORDS_MASK (POOL_WORDS - 1)
+ #define POOL_TAP1 26
+@@ -48,6 +50,8 @@
  #define EXTRACT_LEN 16
  #define MIN_READY_MARK 2
  
@@ -9,7 +18,7 @@
  static u32 pool[POOL_WORDS];
  static unsigned int input_rotate = 0;
  static unsigned int pool_pos = 0;
-@@ -120,7 +122,7 @@ static void random_extract(u8 *out)
+@@ -128,7 +132,7 @@ static void random_extract(u8 *out)
  }
  
  
  {
        struct os_time t;
        static unsigned int count = 0;
-@@ -260,3 +262,22 @@ void random_mark_pool_ready(void)
+@@ -197,16 +201,22 @@ int random_get_bytes(void *buf, size_t l
+ int random_pool_ready(void)
+ {
+ #ifdef __linux__
++      struct stat st;
+       int fd;
+       ssize_t res;
++      if (stat(RANDOM_STAMPFILE, &st) == 0)
++              return 1;
++
+       /*
+        * Make sure that there is reasonable entropy available before allowing
+        * some key derivation operations to proceed.
+        */
+-      if (dummy_key_avail == sizeof(dummy_key))
++      if (dummy_key_avail == sizeof(dummy_key)) {
++              random_mark_pool_ready();
+               return 1; /* Already initialized - good to continue */
++      }
+       /*
+        * Try to fetch some more data from the kernel high quality
+@@ -241,6 +251,7 @@ int random_pool_ready(void)
+       if (dummy_key_avail == sizeof(dummy_key)) {
+               if (own_pool_ready < MIN_READY_MARK)
+                       own_pool_ready = MIN_READY_MARK;
++              random_mark_pool_ready();
+               random_write_entropy();
+               return 1;
+       }
+@@ -253,6 +264,7 @@ int random_pool_ready(void)
+           total_collected + 10 * own_pool_ready > MIN_COLLECT_ENTROPY) {
+               wpa_printf(MSG_INFO, "random: Allow operation to proceed "
+                          "based on internal entropy");
++              random_mark_pool_ready();
+               return 1;
+       }
+@@ -268,10 +280,16 @@ int random_pool_ready(void)
+ void random_mark_pool_ready(void)
+ {
++      int fd;
++
+       own_pool_ready++;
        wpa_printf(MSG_DEBUG, "random: Mark internal entropy pool to be "
                   "ready (count=%u/%u)", own_pool_ready, MIN_READY_MARK);
+       random_write_entropy();
++
++      fd = open(RANDOM_STAMPFILE, O_CREAT | O_WRONLY | O_EXCL | O_NOFOLLOW, 0600);
++      if (fd >= 0)
++              close(fd);
+ }
+@@ -428,3 +446,22 @@ void random_deinit(void)
+       os_free(random_entropy_file);
+       random_entropy_file = NULL;
  }
 +
 +#endif /* CONFIG_NO_RANDOM_POOL */
 +      random_pool_add_randomness(buf, len);
 +#endif
 +}
---- a/hostapd/Makefile
-+++ b/hostapd/Makefile
-@@ -698,11 +698,11 @@ endif
- ifdef CONFIG_NO_RANDOM_POOL
- CFLAGS += -DCONFIG_NO_RANDOM_POOL
- else
--OBJS += ../src/crypto/random.o
--HOBJS += ../src/crypto/random.o
- HOBJS += $(SHA1OBJS)
- HOBJS += ../src/crypto/md5.o
- endif
-+OBJS += ../src/crypto/random.o
-+HOBJS += ../src/crypto/random.o
- ifdef CONFIG_RADIUS_SERVER
- CFLAGS += -DRADIUS_SERVER
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -1101,9 +1101,8 @@ endif
+@@ -1137,9 +1137,8 @@ endif
  
  ifdef CONFIG_NO_RANDOM_POOL
  CFLAGS += -DCONFIG_NO_RANDOM_POOL
  ifeq ($(CONFIG_CTRL_IFACE), y)
 --- a/wpa_supplicant/Android.mk
 +++ b/wpa_supplicant/Android.mk
-@@ -1102,9 +1102,8 @@ endif
+@@ -1132,9 +1132,8 @@ endif
  
  ifdef CONFIG_NO_RANDOM_POOL
  L_CFLAGS += -DCONFIG_NO_RANDOM_POOL
  ifeq ($(CONFIG_CTRL_IFACE), y)
 --- a/hostapd/Android.mk
 +++ b/hostapd/Android.mk
-@@ -717,11 +717,11 @@ endif
+@@ -720,11 +720,11 @@ endif
  ifdef CONFIG_NO_RANDOM_POOL
  L_CFLAGS += -DCONFIG_NO_RANDOM_POOL
  else
  
  ifdef CONFIG_RADIUS_SERVER
  L_CFLAGS += -DRADIUS_SERVER
---- a/src/crypto/random.h
-+++ b/src/crypto/random.h
-@@ -16,15 +16,14 @@
- #define RANDOM_H
- #ifdef CONFIG_NO_RANDOM_POOL
--#define random_add_randomness(b, l) do { } while (0)
- #define random_get_bytes(b, l) os_get_random((b), (l))
- #define random_pool_ready() 1
- #define random_mark_pool_ready() do { } while (0)
- #else /* CONFIG_NO_RANDOM_POOL */
--void random_add_randomness(const void *buf, size_t len);
- int random_get_bytes(void *buf, size_t len);
- int random_pool_ready(void);
- void random_mark_pool_ready(void);
- #endif /* CONFIG_NO_RANDOM_POOL */
-+void random_add_randomness(const void *buf, size_t len);
- #endif /* RANDOM_H */
+--- a/hostapd/Makefile
++++ b/hostapd/Makefile
+@@ -707,12 +707,12 @@ endif
+ ifdef CONFIG_NO_RANDOM_POOL
+ CFLAGS += -DCONFIG_NO_RANDOM_POOL
+ else
+-OBJS += ../src/crypto/random.o
+-HOBJS += ../src/crypto/random.o
+ HOBJS += ../src/utils/eloop.o
+ HOBJS += $(SHA1OBJS)
+ HOBJS += ../src/crypto/md5.o
+ endif
++OBJS += ../src/crypto/random.o
++HOBJS += ../src/crypto/random.o
+ ifdef CONFIG_RADIUS_SERVER
+ CFLAGS += -DRADIUS_SERVER