build variants: only build opkg packages for the requested build variant (or any...
[openwrt-10.03/.git] / package / hostapd / Makefile
index 5e10ea27b960e32c8495ce663fafbb44dc5c9836..bb497fec3b09136e541b25bb33c4d4e8498cacc6 100644 (file)
@@ -108,7 +108,7 @@ define Build/Compile
                hostapd hostapd_cli
 endef
 
-define Package/InstallTemplate
+define Package/hostapd/install
        $(INSTALL_DIR) $(1)/etc/hotplug.d/net
        $(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
        $(INSTALL_DIR) $(1)/lib/wifi
@@ -116,12 +116,7 @@ define Package/InstallTemplate
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
 endef
-
-ifeq ($(BUILD_VARIANT),full)
-  Package/hostapd/install = $(Package/InstallTemplate)
-else
-  Package/hostapd-mini/install = $(Package/InstallTemplate)
-endif
+Package/hostapd-mini/install = $(Package/hostapd/install)
 
 define Package/hostapd-utils/install
        $(INSTALL_DIR) $(1)/usr/sbin