add missing dependencies on PCI/PCMCIA/USB support
[openwrt-10.03/.git] / package / hostap-driver / Makefile
index 9ade13ec6578b2c756b8839daa1f1710427af997..b784131a1d3aaf9cb9344d5d04087543b8688c32 100644 (file)
@@ -70,7 +70,7 @@ endef
 
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
-  DEPENDS:=kmod-hostap
+  DEPENDS:=@PCI_SUPPORT kmod-hostap
   TITLE:=Host AP driver for PCI adaptors
   KCONFIG:=CONFIG_HOSTAP_PCI
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
@@ -91,7 +91,7 @@ endef
 
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
-  DEPENDS:=kmod-hostap
+  DEPENDS:=@PCI_SUPPORT kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
   TITLE:=Host AP driver for PLX9052 based PCI adaptors
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)