get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / grub / Makefile
index 7dfd1429d209dc8002792d7f1a44f25afa69c51e..e828ec0338c0d02b676828ab59aa1d3d2e92e480 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4855 2006-09-24 20:49:31Z nico $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -22,6 +21,8 @@ PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
 
+export grub_cv_prog_objcopy_absolute=yes
+
 define Package/grub
   SECTION:=boot
   DEPENDS:=@TARGET_x86
@@ -45,6 +46,7 @@ else
 CONFIGURE_FLAGS:=
 endif
 
+ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                LDFLAGS="-static" \
@@ -83,5 +85,6 @@ define Build/InstallDev
                install
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
+endif
 
 $(eval $(call BuildPackage,grub))