make grub compilable under fedora core 8 and other newer distros
[openwrt-10.03/.git] / package / grub / Makefile
index 7dfd1429d209dc8002792d7f1a44f25afa69c51e..7e6f3527ecac5210e89bc9e3470a44e47f619d65 100644 (file)
@@ -22,6 +22,8 @@ PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
 
+export grub_cv_prog_objcopy_absolute=yes
+
 define Package/grub
   SECTION:=boot
   DEPENDS:=@TARGET_x86
@@ -45,6 +47,7 @@ else
 CONFIGURE_FLAGS:=
 endif
 
+ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                LDFLAGS="-static" \
@@ -83,5 +86,6 @@ define Build/InstallDev
                install
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
+endif
 
 $(eval $(call BuildPackage,grub))