x86: don't attempt to compile grub on darwin
[openwrt-10.03/.git] / package / grub / Makefile
index 7dfd1429d209dc8002792d7f1a44f25afa69c51e..434af2bc9b78a8b98521f81cd349ceaa5360b871 100644 (file)
@@ -45,6 +45,7 @@ else
 CONFIGURE_FLAGS:=
 endif
 
+ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                LDFLAGS="-static" \
@@ -83,5 +84,6 @@ define Build/InstallDev
                install
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
+endif
 
 $(eval $(call BuildPackage,grub))