[backfire] cleanup: toolchain/uClibc: remove "broken" stuff
[openwrt-10.03/.git] / package / gdb / Makefile
index a2d5c85348eb7bcd25ede760de3f2d867950bc0b..1207fa148771a6df1803275f4cdfe675e5acfee8 100644 (file)
@@ -1,66 +1,79 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.3
-PKG_RELEASE:=1
+PKG_VERSION:=6.8
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/gdb
+define Package/gdb/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libreadline +libncurses
-  TITLE:=GNU Debugger
+  DEPENDS:=@!(avr32||cris)
 endef
 
-define Package/gdbserver
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Remote server for GNU Debugger
+define Package/gdb
+$(call Package/gdb/Default)
+  TITLE:=GNU Debugger
+  DEPENDS+=+libreadline +libncurses
 endef
 
 define Package/gdb/description
- GNU debugger
+GDB, the GNU Project debugger, allows you to see what is going on `inside'
+another program while it executes -- or what another program was doing at the
+moment it crashed.
+endef
+
+define Package/gdbserver
+$(call Package/gdb/Default)
+  TITLE:=Remote server for GNU Debugger
 endef
 
 define Package/gdbserver/description
- GDBSERVER is a program that allows you to run GDB on a different machine 
- than the one which is running the program being debugged.
+GDBSERVER is a program that allows you to run GDB on a different machine than the
+one which is running the program being debugged.
 endef
 
-TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include
-TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+# XXX: add --disable-werror to prevent build failure with arm
+CONFIGURE_ARGS+= \
+       --with-system-readline \
+       --without-expat \
+       --disable-werror
 
-export ac_cv_search_tgetent=$(TARGET_LDFLAGS) -lncurses -lreadline
+CONFIGURE_VARS+= \
+       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install-gdb
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               install-gdb
 endef
 
-define Package/gdb/install     
+define Package/gdb/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
 endef
 
-define Package/gdbserver/install       
+define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gdb))
 $(eval $(call BuildPackage,gdbserver))
-