[backfire] firewall: merge r28527
[openwrt-10.03/.git] / package / firewall / Makefile
index 2e236fe719773fd2c26512def686aa7459e73792..79554f99ddf644ab81c25fc5b4bc1cb5c5ae4472 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
 
-PKG_VERSION:=1
-PKG_RELEASE:=7
+PKG_VERSION:=2
+PKG_RELEASE:=34.2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,12 +18,13 @@ define Package/firewall
   CATEGORY:=Base system
   URL:=http://openwrt.org/
   TITLE:=OpenWrt firewall
-  DEPENDS:=+iptables-mod-conntrack +iptables-mod-nat
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+  DEPENDS:=+iptables +iptables-mod-conntrack +iptables-mod-nat
   PKGARCH:=all
 endef
 
 define Package/firewall/description
uci based firewall for openwrt
UCI based firewall for OpenWrt
 endef
 
 define Build/Compile
@@ -32,17 +33,22 @@ endef
 
 define Package/firewall/conffiles
 /etc/config/firewall
+/etc/firewall.user
 endef
 
 define Package/firewall/install
        $(INSTALL_DIR) $(1)/lib/firewall
-       $(INSTALL_DATA) ./files/uci_firewall.sh $(1)/lib/firewall
+       $(INSTALL_DATA) ./files/lib/*.sh $(1)/lib/firewall
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) ./files/bin/fw $(1)/sbin
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/20-firewall $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/firewall
+       $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/firewall.user $(1)/etc
 endef