Upgrade dropbear to 0.50 (#2201)
[openwrt-10.03/.git] / package / dropbear / Makefile
index e7144a60dfa75795d34ea314405569e37d9acde1..c4816f116d0c6294a584980ca008a8116a32acb3 100644 (file)
@@ -1,84 +1,99 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.46
-PKG_RELEASE:=1
-PKG_MD5SUM:=f0e535a62b57e5bde9ecba4a11402178
+PKG_VERSION:=0.50
+PKG_RELEASE:=3
 
-PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
+       http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
+PKG_MD5SUM:=5c0f7405b915799c3d952d3a93a5df69
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+include $(INCLUDE_DIR)/package.mk
 
-include $(TOPDIR)/package/rules.mk
+define Package/dropbear/Default
+  URL:=http://matt.ucc.asn.au/dropbear/
+endef
 
-$(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/dropbear
+  $(call Package/dropbear/Default)
+  SECTION:=net
+  CATEGORY:=Base system
+  TITLE:=Small SSH2 client/server
+  DESCRIPTION:=\
+       A small SSH2 server/client designed for small memory environments.
+endef
 
-$(PKG_BUILD_DIR)/.configured:
+define Package/dropbearconvert
+  $(call Package/dropbear/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Utility for converting SSH keys
+endef
+
+CONFIGURE_ARGS += \
+       --with-shared \
+       --disable-pam \
+       --enable-openpty \
+       --enable-syslog \
+       --disable-shadow \
+       --disable-lastlog \
+       --disable-utmp \
+       --disable-utmpx \
+       --disable-wtmp \
+       --disable-wtmpx \
+       --disable-loginfunc \
+       --disable-pututline \
+       --disable-pututxline \
+       --disable-zlib
+
+define Build/Configure
        $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
        $(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               autoconf; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --program-prefix="" \
-               --program-suffix="" \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --datadir=/usr/share \
-               --includedir=/usr/include \
-               --infodir=/usr/share/info \
-               --libdir=/usr/lib \
-               --libexecdir=/usr/lib \
-               --localstatedir=/var \
-               --mandir=/usr/share/man \
-               --sbindir=/usr/sbin \
-               --sysconfdir=/etc \
-               $(DISABLE_LARGEFILE) \
-               $(DISABLE_NLS) \
-               --with-shared \
-               --disable-pam \
-               --enable-openpty \
-               --enable-syslog \
-               --disable-shadow \
-               --disable-lastlog \
-               --disable-utmp \
-               --disable-utmpx \
-               --disable-wtmp \
-               --disable-wtmpx \
-               --disable-loginfunc \
-               --disable-pututline \
-               --disable-pututxline \
-       );
-       touch $@
+       $(call Build/Configure/Default)
+endef
 
-$(PKG_BUILD_DIR)/.built:
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               LD=$(TARGET_CC) \
-               PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
+               $(TARGET_CONFIGURE_OPTS) \
+               LD="$(TARGET_CC)" \
+               PROGRAMS="dropbear dbclient dropbearkey scp" \
                MULTI=1 SCPPROGRESS=1
-       touch $@
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               LD="$(TARGET_CC)" \
+               PROGRAMS="dropbearconvert"
+endef
+       
+define Package/dropbear/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
+       $(INSTALL_DIR) $(1)/usr/bin
+       ln -sf ../sbin/dropbear $(1)/usr/bin/scp
+       ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
+       ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
+       ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
+       $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
+       echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
+       echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
+endef
+
+define Package/dropbearconvert/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert $(1)/usr/bin/dropbearconvert
+endef
 
-$(IPKG_DROPBEAR):
-       mkdir -p $(IDIR_DROPBEAR)/usr/bin
-       mkdir -p $(IDIR_DROPBEAR)/usr/sbin
-       install -m 755 $(PKG_BUILD_DIR)/dropbearmulti \
-               $(IDIR_DROPBEAR)/usr/sbin/dropbear
-       $(STRIP) $(IDIR_DROPBEAR)/usr/sbin/dropbear
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/scp
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearconvert
-       mkdir -p $(IDIR_DROPBEAR)/etc/init.d
-       install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
-       $(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
+$(eval $(call BuildPackage,dropbear))
+$(eval $(call BuildPackage,dropbearconvert))