get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / dnsmasq / Makefile
index d3ce64736b7aa371eb16861cb7450cee4d3fd12c..1b030d1ad0268bbb28046233eda613aa34fd9a61 100644 (file)
@@ -1,35 +1,53 @@
-# $Id$
+# 
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.27
-PKG_RELEASE:=1
+PKG_VERSION:=2.47
+PKG_RELEASE:=3
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
-PKG_CAT:=zcat
+PKG_MD5SUM:=4524081e56d0b935717d493e8e8d3e11
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/dnsmasq
-SECTION:=base
-CATEGORY:=Network
-DEFAULT:=y
-TITLE:=A lightweight DNS and DHCP server
-DESCRIPTION:=A lightweight DNS and DHCP server.  It is intended to provide \\\
-coupled DNS and DHCP service to a LAN.
-URL:=http://www.thekelleys.org.uk/dnsmasq/
+  SECTION:=net
+  CATEGORY:=Base system
+  TITLE:=A lightweight DNS and DHCP server
+  URL:=http://www.thekelleys.org.uk/dnsmasq/
+endef
+
+define Package/dnsmasq/description
+ It is intended to provide coupled DNS and DHCP service to a LAN.
+endef
+
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
+               all
 endef
 
 define Package/dnsmasq/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 -d $(1)/etc/init.d/
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
-       install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
-       install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef
 
 $(eval $(call BuildPackage,dnsmasq))