[backfire] dnsmasq: backport r29375
[openwrt-10.03/.git] / package / dnsmasq / Makefile
index cd4cae4be90f554e2294feeb0b8439959a780efa..19eb663340143af8cee3594d8c8d7451777de655 100644 (file)
@@ -1,9 +1,55 @@
+# 
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
-include ./dnsmasq.mk
+PKG_NAME:=dnsmasq
+PKG_VERSION:=2.55
+PKG_RELEASE:=6.1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
+PKG_MD5SUM:=b093d7c6bc7f97ae6fd35d048529232a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dnsmasq
+  SECTION:=net
+  CATEGORY:=Base system
+  TITLE:=A lightweight DNS and DHCP server
+  URL:=http://www.thekelleys.org.uk/dnsmasq/
+endef
+
+define Package/dnsmasq/description
+ It is intended to provide coupled DNS and DHCP service to a LAN.
+endef
+
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+/etc/dnsmasq.conf
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
+               all
+endef
+
+define Package/dnsmasq/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+endef
 
-source: dnsmasq-source
-prepare: $(DNSMASQ_DIR)/.unpacked
-compile: $(DNSMASQ_DIR)/src/dnsmasq
-install: dnsmasq
-clean: dnsmasq-dirclean
+$(eval $(call BuildPackage,dnsmasq))