[backfire] dnsmasq: backport r29375
[openwrt-10.03/.git] / package / dnsmasq / Makefile
index cb723d528f1c47a55f1aa37e6e0ee73c7803d409..19eb663340143af8cee3594d8c8d7451777de655 100644 (file)
@@ -1,20 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.40
-PKG_RELEASE:=1
+PKG_VERSION:=2.55
+PKG_RELEASE:=6.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=91b6063ae81146b9d70b4381b2f3e44f
+PKG_MD5SUM:=b093d7c6bc7f97ae6fd35d048529232a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,19 +24,21 @@ define Package/dnsmasq
   URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
-define Package/dnsmasq/conffiles
-/etc/dnsmasq.conf
-endef
-
 define Package/dnsmasq/description
  It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+/etc/dnsmasq.conf
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
                all
 endef