[backfire] dnsmasq: backport r29375
[openwrt-10.03/.git] / package / dnsmasq / Makefile
index 6e4c2229c45089e0bfe8163eb0fb57b0189c54d8..19eb663340143af8cee3594d8c8d7451777de655 100644 (file)
@@ -1,20 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.41
-PKG_RELEASE:=1
+PKG_VERSION:=2.55
+PKG_RELEASE:=6.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=b067598c3e9b91819a8be5cb59cbf90e
+PKG_MD5SUM:=b093d7c6bc7f97ae6fd35d048529232a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,11 +28,17 @@ define Package/dnsmasq/description
  It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+/etc/dnsmasq.conf
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
                all
 endef
 
@@ -42,6 +47,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef