modify the kconfig system for openwrt
[openwrt-10.03/.git] / package / config / Makefile
index 455a33d233ae2af2350e0bffba610c7912f904bf..9e841d998eca29c17698d7b72533ac3b37b89a1e 100644 (file)
@@ -2,6 +2,7 @@
 #
 # Copyright (C) 2002-2004 Erik Andersen <andersen@codepoet.org>
 
+CP=cp -fpR
 
 # Select the compiler needed to build binaries for your development system
 HOSTCC    = gcc
@@ -77,16 +78,16 @@ lex.zconf.o: lex.zconf.c $(SHARED_DEPS)
        $(HOSTCC) $(HOSTCFLAGS) -I. -c $< -o $@
 
 lex.zconf.c: lex.zconf.c_shipped
-       cp lex.zconf.c_shipped lex.zconf.c
+       $(CP) lex.zconf.c_shipped lex.zconf.c
 
 zconf.tab.o: zconf.tab.c lex.zconf.c confdata.c expr.c symbol.c menu.c $(SHARED_DEPS)
        $(HOSTCC) $(HOSTCFLAGS) -I. -c $< -o $@
 
 zconf.tab.c: zconf.tab.c_shipped
-       cp zconf.tab.c_shipped zconf.tab.c
+       $(CP) zconf.tab.c_shipped zconf.tab.c
 
 zconf.tab.h: zconf.tab.h_shipped
-       cp zconf.tab.h_shipped zconf.tab.h
+       $(CP) zconf.tab.h_shipped zconf.tab.h
 endif
 
 .PHONY: ncurses