[package] busybox: update to v1.12.4 (partially closes: #4279)
[openwrt-10.03/.git] / package / busybox / patches / 300-netmsg.patch
index efc4c337c2a1ca9775bb2bdfe0860bbc04ed47b3..ae5be7eeadd3de1d485740e8ce0f5173685b89e0 100644 (file)
@@ -1,45 +1,58 @@
-diff -Nur busybox-1.1.1/include/applets.h busybox-1.1.1-owrt/include/applets.h
---- busybox-1.1.1/include/applets.h    2006-04-01 18:26:21.000000000 +0200
-+++ busybox-1.1.1-owrt/include/applets.h       2006-04-01 18:36:28.000000000 +0200
-@@ -197,6 +197,7 @@
- USE_MV(APPLET(mv, mv_main, _BB_DIR_BIN, _BB_SUID_NEVER))
- USE_NAMEIF(APPLET(nameif, nameif_main, _BB_DIR_SBIN, _BB_SUID_NEVER))
- USE_NC(APPLET(nc, nc_main, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
-+USE_NETMSG(APPLET_NOUSAGE("netmsg", netmsg_main, _BB_DIR_BIN, _BB_SUID_ALWAYS))
- USE_NETSTAT(APPLET(netstat, netstat_main, _BB_DIR_BIN, _BB_SUID_NEVER))
- USE_NICE(APPLET(nice, nice_main, _BB_DIR_BIN, _BB_SUID_NEVER))
- USE_NOHUP(APPLET(nohup, nohup_main, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
-diff -Nur busybox-1.1.1/networking/Config.in busybox-1.1.1-owrt/networking/Config.in
---- busybox-1.1.1/networking/Config.in 2006-03-22 22:16:19.000000000 +0100
-+++ busybox-1.1.1-owrt/networking/Config.in    2006-04-01 18:35:32.000000000 +0200
-@@ -451,6 +451,12 @@
-       help
+--- a/include/applets.h
++++ b/include/applets.h
+@@ -261,6 +261,7 @@ USE_MT(APPLET(mt, _BB_DIR_BIN, _BB_SUID_
+ USE_MV(APPLET(mv, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NAMEIF(APPLET(nameif, _BB_DIR_SBIN, _BB_SUID_NEVER))
+ USE_NC(APPLET(nc, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
++USE_NETMSG(APPLET(netmsg, _BB_DIR_BIN, _BB_SUID_ALWAYS))
+ USE_NETSTAT(APPLET(netstat, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NICE(APPLET(nice, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NMETER(APPLET(nmeter, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
+--- a/include/usage.h
++++ b/include/usage.h
+@@ -2816,6 +2816,9 @@
+ #endif
++#define netmsg_trivial_usage NOUSAGE_STR
++#define netmsg_full_usage ""
++
+ #define netstat_trivial_usage \
+        "[-laentuwxr"USE_FEATURE_NETSTAT_WIDE("W")USE_FEATURE_NETSTAT_PRG("p")"]"
+ #define netstat_full_usage "\n\n" \
+--- a/networking/Config.in
++++ b/networking/Config.in
+@@ -603,6 +603,12 @@ config NC
          A simple Unix utility which reads and writes data across network
          connections.
-+        
-+config CONFIG_NETMSG
++config NETMSG
 +      bool "netmsg"
 +      default n
 +      help
 +        simple program for sending udp broadcast messages
- config CONFIG_NC_GAPING_SECURITY_HOLE
-       bool "gaping security hole"
-diff -Nur busybox-1.1.1/networking/Makefile.in busybox-1.1.1-owrt/networking/Makefile.in
---- busybox-1.1.1/networking/Makefile.in       2006-03-22 22:16:19.000000000 +0100
-+++ busybox-1.1.1-owrt/networking/Makefile.in  2006-04-01 18:35:32.000000000 +0200
-@@ -30,6 +30,7 @@
- NETWORKING-$(CONFIG_IPTUNNEL)     += iptunnel.o
- NETWORKING-$(CONFIG_NAMEIF)       += nameif.o
- NETWORKING-$(CONFIG_NC)           += nc.o
-+NETWORKING-$(CONFIG_NETMSG)       += netmsg.o
- NETWORKING-$(CONFIG_NETSTAT)      += netstat.o
- NETWORKING-$(CONFIG_NSLOOKUP)     += nslookup.o
- NETWORKING-$(CONFIG_PING)         += ping.o
-diff -Nur busybox-1.1.1/networking/netmsg.c busybox-1.1.1-owrt/networking/netmsg.c
---- busybox-1.1.1/networking/netmsg.c  1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.1.1-owrt/networking/netmsg.c     2006-04-01 18:35:32.000000000 +0200
-@@ -0,0 +1,58 @@
++
+ config NC_SERVER
+       bool "Netcat server options (-l)"
+       default n
+--- a/networking/Kbuild
++++ b/networking/Kbuild
+@@ -24,6 +24,7 @@ lib-$(CONFIG_IP)           += ip.o
+ lib-$(CONFIG_IPCALC)       += ipcalc.o
+ lib-$(CONFIG_NAMEIF)       += nameif.o
+ lib-$(CONFIG_NC)           += nc.o
++lib-$(CONFIG_NETMSG)       += netmsg.o
+ lib-$(CONFIG_NETSTAT)      += netstat.o
+ lib-$(CONFIG_NSLOOKUP)     += nslookup.o
+ lib-$(CONFIG_PING)         += ping.o
+--- /dev/null
++++ b/networking/netmsg.c
+@@ -0,0 +1,63 @@
++/*
++ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
++ *
++ * This is free software, licensed under the GNU General Public License v2.
++ */
 +#include <sys/types.h>
 +#include <sys/socket.h>
 +#include <netinet/in.h>
@@ -56,7 +69,7 @@ diff -Nur busybox-1.1.1/networking/netmsg.c busybox-1.1.1-owrt/networking/netmsg
 +int netmsg_main(int argc, char **argv)
 +#endif
 +{
-+      int s, i;
++      int s;
 +      struct sockaddr_in addr;
 +      int optval = 1;
 +      unsigned char buf[1001];