[package] busybox: update to v1.12.4 (partially closes: #4279)
[openwrt-10.03/.git] / package / busybox / patches / 300-netmsg.patch
index ac1a0aaaa852ea53b8f21cd6903128ddb01d7c77..ae5be7eeadd3de1d485740e8ce0f5173685b89e0 100644 (file)
@@ -1,47 +1,58 @@
-diff -urN busybox.old/include/applets.h busybox.dev/include/applets.h
---- busybox.old/include/applets.h      2006-01-11 01:32:47.302791000 +0100
-+++ busybox.dev/include/applets.h      2006-01-11 01:33:18.744756250 +0100
-@@ -475,6 +475,9 @@
- #ifdef CONFIG_NC
-       APPLET(nc, nc_main, _BB_DIR_USR_BIN, _BB_SUID_NEVER)
- #endif
-+#ifdef CONFIG_NETMSG
-+      APPLET_NOUSAGE("netmsg", netmsg_main, _BB_DIR_BIN, _BB_SUID_ALWAYS)
-+#endif
- #ifdef CONFIG_NETSTAT
-       APPLET(netstat, netstat_main, _BB_DIR_BIN, _BB_SUID_NEVER)
+--- a/include/applets.h
++++ b/include/applets.h
+@@ -261,6 +261,7 @@ USE_MT(APPLET(mt, _BB_DIR_BIN, _BB_SUID_
+ USE_MV(APPLET(mv, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NAMEIF(APPLET(nameif, _BB_DIR_SBIN, _BB_SUID_NEVER))
+ USE_NC(APPLET(nc, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
++USE_NETMSG(APPLET(netmsg, _BB_DIR_BIN, _BB_SUID_ALWAYS))
+ USE_NETSTAT(APPLET(netstat, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NICE(APPLET(nice, _BB_DIR_BIN, _BB_SUID_NEVER))
+ USE_NMETER(APPLET(nmeter, _BB_DIR_USR_BIN, _BB_SUID_NEVER))
+--- a/include/usage.h
++++ b/include/usage.h
+@@ -2816,6 +2816,9 @@
  #endif
-diff -urN busybox.old/networking/Config.in busybox.dev/networking/Config.in
---- busybox.old/networking/Config.in   2005-11-01 00:55:15.000000000 +0100
-+++ busybox.dev/networking/Config.in   2006-01-11 01:33:18.744756250 +0100
-@@ -435,6 +435,12 @@
-       help
++#define netmsg_trivial_usage NOUSAGE_STR
++#define netmsg_full_usage ""
++
+ #define netstat_trivial_usage \
+        "[-laentuwxr"USE_FEATURE_NETSTAT_WIDE("W")USE_FEATURE_NETSTAT_PRG("p")"]"
+ #define netstat_full_usage "\n\n" \
+--- a/networking/Config.in
++++ b/networking/Config.in
+@@ -603,6 +603,12 @@ config NC
          A simple Unix utility which reads and writes data across network
          connections.
-+        
-+config CONFIG_NETMSG
++config NETMSG
 +      bool "netmsg"
 +      default n
 +      help
 +        simple program for sending udp broadcast messages
- config CONFIG_NC_GAPING_SECURITY_HOLE
-       bool "gaping security hole"
-diff -urN busybox.old/networking/Makefile.in busybox.dev/networking/Makefile.in
---- busybox.old/networking/Makefile.in 2005-11-01 00:55:15.000000000 +0100
-+++ busybox.dev/networking/Makefile.in 2006-01-11 01:34:02.939518250 +0100
-@@ -28,6 +28,7 @@
- NETWORKING-$(CONFIG_IPTUNNEL)     += iptunnel.o
- NETWORKING-$(CONFIG_NAMEIF)       += nameif.o
- NETWORKING-$(CONFIG_NC)           += nc.o
-+NETWORKING-$(CONFIG_NETMSG)       += netmsg.o
- NETWORKING-$(CONFIG_NETSTAT)      += netstat.o
- NETWORKING-$(CONFIG_NSLOOKUP)     += nslookup.o
- NETWORKING-$(CONFIG_PING)         += ping.o
-diff -urN busybox.old/networking/netmsg.c busybox.dev/networking/netmsg.c
---- busybox.old/networking/netmsg.c    1970-01-01 01:00:00.000000000 +0100
-+++ busybox.dev/networking/netmsg.c    2006-01-11 01:33:18.748756500 +0100
-@@ -0,0 +1,58 @@
++
+ config NC_SERVER
+       bool "Netcat server options (-l)"
+       default n
+--- a/networking/Kbuild
++++ b/networking/Kbuild
+@@ -24,6 +24,7 @@ lib-$(CONFIG_IP)           += ip.o
+ lib-$(CONFIG_IPCALC)       += ipcalc.o
+ lib-$(CONFIG_NAMEIF)       += nameif.o
+ lib-$(CONFIG_NC)           += nc.o
++lib-$(CONFIG_NETMSG)       += netmsg.o
+ lib-$(CONFIG_NETSTAT)      += netstat.o
+ lib-$(CONFIG_NSLOOKUP)     += nslookup.o
+ lib-$(CONFIG_PING)         += ping.o
+--- /dev/null
++++ b/networking/netmsg.c
+@@ -0,0 +1,63 @@
++/*
++ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
++ *
++ * This is free software, licensed under the GNU General Public License v2.
++ */
 +#include <sys/types.h>
 +#include <sys/socket.h>
 +#include <netinet/in.h>
@@ -58,13 +69,13 @@ diff -urN busybox.old/networking/netmsg.c busybox.dev/networking/netmsg.c
 +int netmsg_main(int argc, char **argv)
 +#endif
 +{
-+      int s, i;
++      int s;
 +      struct sockaddr_in addr;
 +      int optval = 1;
 +      unsigned char buf[1001];
 +
-+      if (argc != 2) {
-+              fprintf(stderr, "usage: %s \"message\"\n", argv[0]);
++      if (argc != 3) {
++              fprintf(stderr, "usage: %s <ip> \"<message>\"\n", argv[0]);
 +              exit(1);
 +      }
 +
@@ -75,14 +86,14 @@ diff -urN busybox.old/networking/netmsg.c busybox.dev/networking/netmsg.c
 +
 +      memset(&addr, 0, sizeof(addr));
 +      addr.sin_family = AF_INET;
-+      addr.sin_addr.s_addr = htonl(0xffffffff);
++      addr.sin_addr.s_addr = inet_addr(argv[1]);
 +      addr.sin_port = htons(0x1337);
 +
 +      memset(buf, 0, 1001);
 +      buf[0] = 0xde;
 +      buf[1] = 0xad;
 +
-+      strncpy(buf + 2, argv[1], 998);
++      strncpy(buf + 2, argv[2], 998);
 +
 +      if (setsockopt (s, SOL_SOCKET, SO_BROADCAST, (caddr_t) &optval, sizeof (optval)) < 0) {
 +              perror("setsockopt()");