remove some more stuff, change package makefile format in rules.mk, port busybox...
[openwrt-10.03/.git] / package / busybox / Makefile
index 35f954b931ef5e309653718d03ef31f4bdad056a..3ada74532e925c863bf9b590b37a84d398ac962f 100644 (file)
@@ -5,25 +5,23 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=busybox
 PKG_RELEASE:=1
 
-ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
-# Be aware that this changes daily....
-PKG_VERSION:=0.${shell date +"%G%m%d"}
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_SOURCE:=$(PKG_NAME)-snapshot.tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads/snapshots
-PKG_MD5SUM:=x
-else
 PKG_VERSION:=1.1.2
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads
 PKG_MD5SUM:=0b5d78072302fe687407956537bdb9e3
-endif
 PKG_CAT:=bzcat
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,BUSYBOX,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/busybox
+CONFIGFILE:=config/Config.in
+SECTION:=base
+CATEGORY:=Base system
+TITLE:=Core utilities
+DESCRIPTION:=Core utilities for embedded Linux systems
+endef
+$(eval $(call BuildPackage,BUSYBOX,busybox))
 
 $(PKG_BUILD_DIR)/.configured:
        $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config