Add default compile target & use it for bridge and busybox
[openwrt-10.03/.git] / package / bridge / Makefile
index 601373b99494f129ac2803fa717ba21a6002380a..bd71165b6d220ef723197c724d29a460d678cbc5 100644 (file)
@@ -5,45 +5,35 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=bridge
 PKG_VERSION:=1.0.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
 
-PKG_SOURCE_URL:=@SF/bridge
-PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/bridge-utils-$(PKG_VERSION)
+PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/bridge
+PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
 PKG_CAT:=zcat
 
 include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,BRIDGE,bridge,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               $(DISABLE_NLS) \
-               --with-linux-headers=$(LINUX_DIR) \
-       );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       touch $@
-
-$(IPKG_BRIDGE): 
+
+define Package/bridge
+SECTION:=base
+CATEGORY:=Network
+DEFAULT:=y
+TITLE:=Ethernet bridging configuration utility
+DESCRIPTION:=Ethernet bridging configuration utility\\\
+Manage ethernet bridging; a way to connect networks together to\\\
+form a larger network.
+URL:=http://bridge.sourceforge.net/
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--with-linux-headers=$(LINUX_DIR))
+endef
+
+define Package/busybox/install
        mkdir -p $(IDIR_BRIDGE)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/brctl/brctl $(IDIR_BRIDGE)/usr/sbin/
        $(STRIP) $(IDIR_BRIDGE)/usr/sbin/brctl
        $(IPKG_BUILD) $(IDIR_BRIDGE) $(PACKAGE_DIR)
+endef
+
+$(eval $(call BuildPackage,bridge))