get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / bridge-utils / Makefile
index de9bc95d7ab957414002c96b4e9fe97f2dd5ac51..35b883884c8be454507db902c2a841f23c9dd2b5 100644 (file)
@@ -4,18 +4,25 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
-PKG_VERSION:=1.4
 PKG_RELEASE:=1
+PKG_SOURCE_URL:=@SF/bridge
+
+ifeq ($(CONFIG_LINUX_2_4),y)
+  PKG_VERSION:=1.0.6
+  PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
+endif
+
+ifeq ($(CONFIG_LINUX_2_6),y)
+  PKG_VERSION:=1.4
+  PKG_MD5SUM:=0182fcac3a2b307113bbec34e5f1c673
+endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/bridge
-PKG_MD5SUM:=0182fcac3a2b307113bbec34e5f1c673
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,10 +41,13 @@ endef
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       autoconf; \
-       ./configure $(CONFIGURE_ARGS) \
+define Build/Prepare
+$(call Build/Prepare/Default)
+       ( cd $(PKG_BUILD_DIR) ; \
+               [ -f ./configure ] || { \
+                       ln -sf configure.in configure.ac ; \
+                       autoconf ; \
+               } \
        )
 endef