get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / bridge-utils / Makefile
index 6dea48435655515fed99ca4b658cf625d1d6fa5b..35b883884c8be454507db902c2a841f23c9dd2b5 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -42,10 +41,13 @@ endef
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       autoconf; \
-       ./configure $(CONFIGURE_ARGS) \
+define Build/Prepare
+$(call Build/Prepare/Default)
+       ( cd $(PKG_BUILD_DIR) ; \
+               [ -f ./configure ] || { \
+                       ln -sf configure.in configure.ac ; \
+                       autoconf ; \
+               } \
        )
 endef