Fix typo in the payload option for br2684ctl (#3318)
[openwrt-10.03/.git] / package / br2684ctl / Makefile
index 223f6f7c5fd6dd641ca4ecfd9eed0c50bc7750a7..cd668e2f7e4d66f73dd4f9a2560e1d245778cbd3 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
 PKG_MD5SUM:=6eb4d8cd174e24a7c078eb4f594f5b69
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
+PKG_BUILD_DEPENDS:=linux-atm
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,11 +25,11 @@ define Package/$(PKG_NAME)
   SECTION:=net
   CATEGORY:=Base system
   TITLE:=ATM Ethernet bridging configuration utility
-  DESCRIPTION:=ATM Ethernet bridging configuration utility
+  DEPENDS:=+linux-atm
   URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
 endef
 
-MAKE_FLAGS += CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)"
+MAKE_FLAGS += CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)"
 
 define Package/$(PKG_NAME)/install
        $(INSTALL_DIR) $(1)/etc/init.d