implement target profiles in menuconfig
[openwrt-10.03/.git] / package / base-files / Makefile
index f7782196650fedaf9967706ea1b8aeb4e0f9484b..5af1414d4e37f483484f4ffb23ceeb3dd2b94b0d 100644 (file)
@@ -35,7 +35,6 @@ CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 define Package/base-files$(TARGET)
   SECTION:=base
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Base filesystem for OpenWrt
   DESCRIPTION:=\
        This package contains a base filesystem and system scripts for OpenWrt.
@@ -87,7 +86,6 @@ endef
 define Package/libgcc
   SECTION:=libs
   CATEGORY:=Base system
-  DEFAULT:=y
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=GCC support library
   URL:=http://gcc.gnu.org/
@@ -106,7 +104,6 @@ endef
 define Package/uclibc
   SECTION:=libs
   CATEGORY:=Base system
-  DEFAULT:=y
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=C library embedded systems
   URL:=http://uclibc.org/
@@ -122,7 +119,7 @@ define Build/Compile/ar7
 endef
 
 define Build/Compile/brcm
-       $(TARGET_CC) -o $(PKG_BUILD_DIR)/jffs2root src/jffs2root.c
+       $(TARGET_CC) -I src -o $(PKG_BUILD_DIR)/jffs2root src/jffs2root.c
 endef
 
 define Build/Compile