fix broken init file and some cleanup
[openwrt-10.03/.git] / package / admswconfig / Makefile
index 52aa2a467f7e0e5d623c3bca7c054eae47f103b2..96797378ccfdec2eaf8739e3f41ee97b479e42e1 100644 (file)
@@ -43,6 +43,10 @@ endef
 define Package/admswconfig/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/network/
+       $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
 endef
 
 $(eval $(call BuildPackage,admswconfig))