major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / package / admswconfig / Makefile
index c369081be9dfa19cd7beea27d49e5fb3c2c07801..0faec37e700a89a7f43e15470e66e3ff46eb884d 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,10 +13,8 @@ PKG_VERSION:=0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
-PKG_MD5SUM:=3d00efbff699af8a4d3179becd881b1e
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@openwrt/
+PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,15 +22,17 @@ define Package/admswconfig
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=ADM5120 Switch configuration tool
-  DEPENDS:=@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB
-  DESCRIPTION:=\
-       A program to configure the internal ethernet switch of an ADM5120 processor. \\\
-       You need the corresponding driver for the switch in the kernel. \\\
-       with this program you can configure which ports of the switch belong \\\
-       to the different ethernet devices.
+  DEPENDS:=@TARGET_adm5120
   URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
 endef
 
+define Package/admswconfig/description
+ A program to configure the internal ethernet switch of an ADM5120 processor.
+ You need the corresponding driver for the switch in the kernel. 
+ With this program you can configure which ports of the switch belong 
+ to the different ethernet devices.
+endef
+
 define Build/Configure
 endef