major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / package / admswconfig / Makefile
index 10ab5895f1d770a306cc49cf1f90ee7d050826f0..0faec37e700a89a7f43e15470e66e3ff46eb884d 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,23 +16,23 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@openwrt/
 PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
 
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/admswconfig
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=ADM5120 Switch configuration tool
-  DEPENDS:=@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB
-  DESCRIPTION:=\
-       A program to configure the internal ethernet switch of an ADM5120 processor. \\\
-       You need the corresponding driver for the switch in the kernel. \\\
-       with this program you can configure which ports of the switch belong \\\
-       to the different ethernet devices.
+  DEPENDS:=@TARGET_adm5120
   URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
 endef
 
+define Package/admswconfig/description
+ A program to configure the internal ethernet switch of an ADM5120 processor.
+ You need the corresponding driver for the switch in the kernel. 
+ With this program you can configure which ports of the switch belong 
+ to the different ethernet devices.
+endef
+
 define Build/Configure
 endef