replace ipkg-make-index with a shell script that works on bsd
[openwrt-10.03/.git] / package / Makefile
index b6165b856727ee87fba129470404d6ba5601d69b..d2b7468a394a5dd01286f5db5ef17aa77f7d39a6 100644 (file)
@@ -9,6 +9,7 @@
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/.config
 include $(TOPDIR)/.pkgdeps
+include $(TOPDIR)/host.mk
 
 PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-prereq))
 DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
@@ -58,7 +59,7 @@ install:
 index: $(PACKAGE_DIR)/Packages
 
 $(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
-       (cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)
+       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
 
 ifeq ($(MAKECMDGOALS),compile-targets)