Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
[openwrt-10.03/.git] / package / Makefile
index 0713e8d23ebdb83b2c2387376101a7069920a15f..94241dbc3d860c5d875c22ea47789377cf1f7753 100644 (file)
@@ -26,12 +26,16 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prepare %-prereq %-download %-clean %-refresh: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
-%-prepare %-prereq %-download %-clean %-compile %-install %-refresh: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
+%-refresh %-update:
+       -$(MAKE) -C $* $(patsubst $*-%,%,$@)
+
+
 # .IGNORE: $(COMPILE_PACKAGES) 
 
 $(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@@ -42,6 +46,9 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile: $(COMPILE_PACKAGES)
+ifneq ($(QUILT),)
+  refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
+endif
 
 install-targets: $(INSTALL_PACKAGES)
 install: