fix broken .pkginfo under certain situations
[openwrt-10.03/.git] / include / verbose.mk
index c998b3d1c9944740a996bf3b1bc5ebee269564f1..da2a21974adde6c53f781ef02403b06243021d7c 100644 (file)
@@ -6,6 +6,8 @@
 #
 # $Id:$
 
+NO_TRACE_MAKE:=$(MAKE) V=99
+
 ifndef KBUILD_VERBOSE
   KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
@@ -23,7 +25,6 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
-    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
@@ -31,4 +32,6 @@ ifneq ($(KBUILD_VERBOSE),99)
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+   NO_TRACE_MAKE:=$(MAKE)
 endif