fix broken .pkginfo under certain situations
[openwrt-10.03/.git] / include / verbose.mk
index 77a877efe3c4071f55d4bafebc8c18e776aceaad..da2a21974adde6c53f781ef02403b06243021d7c 100644 (file)
@@ -1,14 +1,21 @@
-# OpenWrt.org 2006
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id:$
 
-ifeq ($(DUMP),)
-  ifndef KBUILD_VERBOSE
-    KBUILD_VERBOSE=0
-    ifeq ("$(origin V)", "command line")
-      KBUILD_VERBOSE=$(V)
-    endif
+NO_TRACE_MAKE:=$(MAKE) V=99
+
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE=0
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE=$(V)
   endif
+endif
 
+ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
@@ -18,8 +25,13 @@ ifeq ($(DUMP),)
        }
   else
     export QUIET:=1
-    MAKE:=3>&1 4>&2 $(MAKE)
+    ifeq ($(KBUILD_VERBOSE),0)
+      MAKE:=&>/dev/null $(MAKE)
+    endif
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+   NO_TRACE_MAKE:=$(MAKE)
 endif