[backfire] backport r27648
[openwrt-10.03/.git] / include / verbose.mk
index f795e28045b0c60084a26b83692fe7707ecfaf73..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -18,8 +18,10 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:=\\033[33m
-  _N:=\\033[m
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -44,7 +46,7 @@ ifneq ($(KBUILD_VERBOSE),99)
       SILENT:=
     endif
     export QUIET:=1
-    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)