[backfire] uhttpd: merge r28792
[openwrt-10.03/.git] / include / verbose.mk
index b4242f212acc512c4d66533932bf86838f374eab..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
 
 ifeq ($(NO_TRACE_MAKE),)
 NO_TRACE_MAKE := $(MAKE) V=99
@@ -19,25 +18,41 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:="\\33[33m"# yellow
-  _N:="\\33[m"#        normal
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
+  define MESSAGE
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&8
+  endef
+
   ifeq ($(QUIET),1)
-    $(MAKECMDGOALS): trace
-    trace: FORCE
-       @[ -f "$(MAKECMDGOALS)" ] || { \
-               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
-       }
+    ifneq ($(CURDIR),$(TOPDIR))
+      _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
+    else
+      _DIR:=
+    endif
+    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
+    ))
+    SUBMAKE=$(MAKE)
   else
-    export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
-      MAKE:=&>/dev/null $(MAKE)
+      SILENT:=>/dev/null 2>&1
+    else
+      SILENT:=
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
+    export QUIET:=1
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+  SUBMAKE=$(MAKE) -w
+  define MESSAGE
+    printf "%s\n" "$(1)"
+  endef
 endif