[backfire] uhttpd: merge r28792
[openwrt-10.03/.git] / include / verbose.mk
index 77a877efe3c4071f55d4bafebc8c18e776aceaad..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -1,25 +1,58 @@
-# OpenWrt.org 2006
-# $Id:$
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
-ifeq ($(DUMP),)
-  ifndef KBUILD_VERBOSE
-    KBUILD_VERBOSE=0
-    ifeq ("$(origin V)", "command line")
-      KBUILD_VERBOSE=$(V)
-    endif
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
+
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
+endif
+
+ifeq ($(IS_TTY),1)
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
   endif
+endif
+
+ifneq ($(KBUILD_VERBOSE),99)
+  define MESSAGE
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&8
+  endef
 
   ifeq ($(QUIET),1)
-    $(MAKECMDGOALS): trace
-    trace: FORCE
-       @[ -f "$(MAKECMDGOALS)" ] || { \
-               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
-       }
+    ifneq ($(CURDIR),$(TOPDIR))
+      _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
+    else
+      _DIR:=
+    endif
+    _NULL:=$(if $(MAKECMDGOALS),$(shell \
+               $(call MESSAGE, make[$(MAKELEVEL)]$(if $(_DIR), -C $(_DIR)) $(MAKECMDGOALS)); \
+    ))
+    SUBMAKE=$(MAKE)
   else
+    ifeq ($(KBUILD_VERBOSE),0)
+      SILENT:=>/dev/null 2>&1
+    else
+      SILENT:=
+    endif
     export QUIET:=1
-    MAKE:=3>&1 4>&2 $(MAKE)
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
+else
+  SUBMAKE=$(MAKE) -w
+  define MESSAGE
+    printf "%s\n" "$(1)"
+  endef
 endif