[backfire] backport r27648
[openwrt-10.03/.git] / include / verbose.mk
index 620c2b3f009a3849a5175b0d2fec7c01fc34aa3e..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -18,8 +18,10 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:=\\033[33m
-  _N:=\\033[m
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -44,12 +46,12 @@ ifneq ($(KBUILD_VERBOSE),99)
       SILENT:=
     endif
     export QUIET:=1
-    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)
 else
-  SUBMAKE=$(MAKE)
+  SUBMAKE=$(MAKE) -w
   define MESSAGE
     printf "%s\n" "$(1)"
   endef