add submenu dependencies (used to hide the proprietary broadcom driver on anything...
[openwrt-10.03/.git] / include / verbose.mk
index 1ef403ccfb95a1bce23da75a178621bdf1722874..7d9b3979bffcb171ff025375d4c1324a6ebca5ab 100644 (file)
@@ -1,18 +1,20 @@
-# OpenWrt.org 2006
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id:$
 
+export NO_TRACE_MAKE:=$(MAKE) V=99
+
 ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=0
-  else
-    KBUILD_VERBOSE=99
-  endif
+  KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
     KBUILD_VERBOSE=$(V)
   endif
 endif
 
-
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
@@ -26,7 +28,7 @@ ifneq ($(KBUILD_VERBOSE),99)
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=3>&1 4>&2 $(MAKE)
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)