add support for per-package prereq checks, run global prereq checks before (menu...
[openwrt-10.03/.git] / include / verbose.mk
index 1ef403ccfb95a1bce23da75a178621bdf1722874..525fbf1c157178e6d4e2c4c39fa0a93222e31bba 100644 (file)
@@ -1,17 +1,22 @@
-# OpenWrt.org 2006
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id:$
 
-ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=0
-  else
-    KBUILD_VERBOSE=99
-  endif
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
 endif
 
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
+endif
 
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
@@ -26,7 +31,7 @@ ifneq ($(KBUILD_VERBOSE),99)
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=3>&1 4>&2 $(MAKE)
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)