build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / include / toplevel.mk
index af4b390e4eb04909ee75fc38a24eb55b410fe658..e45626422157bb78cef15a5c798296b80f1abda9 100644 (file)
@@ -94,7 +94,7 @@ download: .config FORCE
        $(MAKE) -j1 package/download
        $(MAKE) -j1 target/download
 
-clean dirclean distclean:
+clean dirclean:
        @$(MAKE) $@ 
 
 prereq:: .config
@@ -118,6 +118,9 @@ symlinkclean:
        -find package -type l | xargs rm -f
        rm -rf tmp
 
+distclean:
+       rm -rf tmp build_dir staging_dir dl .config*
+
 ifeq ($(findstring v,$(DEBUG)),)
   .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target prepare-tmpinfo
 endif