add some sanity checking
[openwrt-10.03/.git] / include / toplevel.mk
index 606e3e5844b45635645958e6f6090f844f078518..e13d66781aaa655f700f434b187fe2a56584aabd 100644 (file)
@@ -45,7 +45,7 @@ prepare-tmpinfo: FORCE
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo
-       @+if [ \! -f .config ]; then \
+       @+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi