add autorebuild check for menuconfig
[openwrt-10.03/.git] / include / toplevel.mk
index 3e391653490d99ef4936b990698e1df459352373..c92686019dc691694f28c76eda004b60d03a7e4d 100644 (file)
@@ -52,6 +52,8 @@ prepare-tmpinfo: FORCE
 scripts/config/mconf:
        @+$(MAKE) -C scripts/config all
 
+$(eval $(call rdep,scripts/config,scripts/config/mconf))
+
 scripts/config/conf:
        @+$(MAKE) -C scripts/config conf
 
@@ -120,7 +122,7 @@ symlinkclean:
        rm -rf tmp
 
 distclean:
-       rm -rf tmp build_dir staging_dir dl .config*
+       rm -rf tmp build_dir staging_dir dl .config* feeds
 
 ifeq ($(findstring v,$(DEBUG)),)
   .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package prepare-tmpinfo