"make distclean" should remove "package/feeds"
[openwrt-10.03/.git] / include / toplevel.mk
index 3c2e46d8b8d85b926212c80224e6be770ff4ca83..1826bc11a70f923bb6e6df98b03cc10bbd1df0be 100644 (file)
@@ -118,12 +118,8 @@ docs docs/compile: FORCE
 docs/clean: FORCE
        $(MAKE) -C docs clean
 
-symlinkclean:
-       -find package -type l | xargs rm -f
-       rm -rf tmp
-
 distclean:
-       rm -rf tmp build_dir staging_dir dl .config* feeds bin
+       rm -rf tmp build_dir staging_dir dl .config* feeds package/feeds bin
 
 ifeq ($(findstring v,$(DEBUG)),)
   .SILENT: symlinkclean clean dirclean distclean config-clean download help tmpinfo-clean .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package prepare-tmpinfo