add autorebuild check for menuconfig
[openwrt-10.03/.git] / include / target.mk
index 1590b9109190027dd3a5e395f6407db83b83a677..9ee369d9b123ee31c508e8f77fc8cecb392d942d 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -75,10 +75,22 @@ define Profile
   endif
 endef
 
-ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
-  -include $(PLATFORM_DIR)/profiles/*.mk
-  ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
     -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endef
+else
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
+  endef
+endif
+
+ifeq ($(TARGET_BUILD),1)
+  $(eval $(call IncludeProfiles))
+else
+  ifeq ($(DUMP),)
+    $(eval $(call IncludeProfiles))
   endif
 endif
 
@@ -138,6 +150,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
+        echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \