[backfire] uhttpd: merge r28792
[openwrt-10.03/.git] / include / subdir.mk
index 81a6f2a428bac257bd0f87a156bb66f533b83ac5..b8094afb2e86188f69f54a949fe03ad6142133c7 100644 (file)
@@ -1,31 +1,25 @@
-# debug flags:
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# d: show subdirectory tree
-# t: show added targets
-# l: show legacy targets
-
-ifeq ($(DEBUG),all)
-  build_debug:=dt
-else
-  build_debug:=$(DEBUG)
-endif
-
-define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
-endef
 
-define warn
-$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
-endef
+SUBTARGETS:=clean download prepare compile install update refresh prereq dist distcheck
+
+subtarget-default = $(filter-out ., \
+       $(if $($(1)/builddirs-$(2)),$($(1)/builddirs-$(2)), \
+       $(if $($(1)/builddirs-default),$($(1)/builddirs-default), \
+       $($(1)/builddirs))))
+
+define subtarget
+  $(call warn_eval,$(1),t,T,$(1)/$(2): $($(1)/) $(foreach bd,$(call subtarget-default,$(1),$(2)),$(1)/$(bd)/$(2)))
 
-define warn_eval
-$(call warn,$(1),$(2),$(3)     $(4))
-$(4)
 endef
 
-dep/compile=$(1)/prepare
-dep/install=$(1)/compile
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+
+lastdir=$(word $(words $(subst /, ,$(1))),$(subst /, ,$(1)))
+diralias=$(if $(findstring $(1),$(call lastdir,$(1))),,$(call lastdir,$(1)))
 
 # Parameters: <subdir>
 define subdir
@@ -33,31 +27,43 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(call dep/$(target),$(1)/$(bd)) $($(1)/$(bd)/$(target)) $($(1)//$(target)))
-               @$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+      $(foreach btype,$(buildtypes-$(bd)),
+        $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(btype)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(btype)/$(target)) $(call $(1)//$(btype)/$(target),$(1)/$(bd)/$(btype))))
+                 +$$(SUBMAKE) -C $(1)/$(bd) $(btype)-$(target) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(btype)-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) [$(btype)] failed to build.))
+        $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(btype)/$(target))
+        $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
+      )
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+               $(if $(BUILD_LOG),@mkdir -p $(BUILD_LOG_DIR)/$(1)/$(bd))
+        $(foreach variant,$(if $(BUILD_VARIANT),$(BUILD_VARIANT),$(if $($(1)/$(bd)/variants),$($(1)/$(bd)/variants),__default)),
+                       +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) BUILD_VARIANT="$(filter-out __default,$(variant))" $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build$(if $(filter-out __default,$(variant)), (build variant: $(variant))).))
+        )
+        $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets
       $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
+      # aliases
+      $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(target): $(1)/$(bd)/$(target)))
        )
   )
-  $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$($(1)/builddirs),$(1)/$(bd)/$(target)))
-  )
+  $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name>
+# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
 define stampfile
-  $(1)/stamp:=$(STAGING_DIR)/stampfiles/.$(2)_installed
-  $(call rdep,$(1),$$($(1)/stamp))
-
-  $$($(1)/stamp):
-       @$(MAKE) $(1)/install
-       @mkdir -p $$$$(dirname $$($(1)/stamp))
-       @touch $$($(1)/stamp)
-  .PRECIOUS: $$($(1)/stamp) # work around a make bug
-
-  $(1)//clean:=$(1)/stamp/clean
-  $(1)/stamp/clean: FORCE
-       @rm -f $$($(1)/stamp)
+  $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+  $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
+       @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
+               $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+       @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
+       @touch $$($(1)/stamp-$(3))
+
+  $$(if $(call debug,$(1),v),,.SILENT: $$($(1)/stamp-$(3)))
+
+  .PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
+
+  $(1)//clean:=$(1)/stamp-$(3)/clean
+  $(1)/stamp-$(3)/clean: FORCE
+       @rm -f $$($(1)/stamp-$(3))
 
 endef